HYDU_create_process, execvp error on file pyfr (No such file or directory)

Hello Team PyFr,

I am currently trying to use PyFR in my college HPC. Got following error, and I am unable to resolve this.

...... HYDU_create_process (../../utils/launch/launch.c:827): execvp error on file pyfr (No such file or directory)
...... HYDU_create_process (../../utils/launch/launch.c:827): execvp error on file pyfr (No such file or directory)

Installed PyFR and related modules one of the environment(as mentioned in the installation procedure of pyfr ) and activated it by following function:
source /home/PyFR/pyfr-venv/bin/activate

Thank you and regards,

So it seems that the system can’t find pyfr. Can you confirm that pyfr is in your path?

I have added the install location of pyfr as path (as I don’t know where exactly the pyfr executable file is).
when I did echo $PATH, got following paths

Ok, and if you where to submit a job that just does mpiexce -n num_of_jobs echo $PATH$ do you see PyFR in the path?

I think I can only see the paths which were provided earlier (in the image of previous comment), after executing your command.

Can I know where exactly the PyFR executable file would be, after doing pip install pyfr?
I just gave the installation location of PyFR as my path till now.

pyfr should be in the bin directory within the virtual environment.

I gave the location mentioned above as path of pyfr executable file for my virtual environment.
Still I am getting the same error.

Is PyFR actually in that directory?

yeah, it is.

What command are you using to launch (or try to launch) PyFR?

Regards, Freddie.

Currently trying to do Euler test case example provided in PyFR website.

This is the command,

$MPIEXEC $FLAGS_MPI_BATCH pyfr run -b cuda -p 2d-euler-vortex.pyfrm 2d-euler-vortex.ini ""

in order to use cuda within pyfr interactively I was recommend to connect to one of the GPU frontends in the cluster, so replaced “mpiexec” with “$MPIEXEC $FLAGS_MPI_BATCH” as per our IT team suggestion.

I run this command line using Slrum batch scripts

And what happens if you replace pyfr with the full path to the executable /home/…/PyFR/pyfr-venv/bin/pyfr?

Regards, Freddie.

this is my output after replacing pyfr with the path

This looks like a problem with your Python installation. Please try running python -c 'print("Hello")' with MPI from your virtual environment.

Regards, Freddie.

But I think I am receiving the output, when " python -c 'print(“Hello”) " is executed.

And what happens if you replace python with the full path to your Python interpreter in your virtual environment?

Regards, Freddie.

Replaced the python with python location.

Still received the same output.

But that is not the path the virtual environment uses which is /home/…/PyFR/pyfr-venv/bin/python and this is what you need to try.

Regards, Freddie.

It did show an error when I replaced the path with /home/…/PyFR/pyfr-venv/bin/python for some reason.
So, I created a new virtual env with following command python3 -m virtualenv pyfr (provided in the pyfr installation page) it has python 3.6.8 when checked.

executed python test command with new virtual env, got the expected output with the path /home/..../pyfr/pyfr/bin/python.
now, when I ran the code with /home/..../pyfr/pyfr/bin/pyfr (after installation of pyfr in virtual env) gave an error, as shown in below image.


You are likely getting a path incorrect, or do not have the relevant directory mounted on the nodes which are actually running the command.

Regards, Freddie.