Problem about partitioning mesh file

Dear all,

I’ve tried to run the 2D Euler Vortex problem with PyFR v.1.4.0. However, when I run pyfr to partition the PyFR mesh file into two pieces, I get the error messages below:

[root@localhost euler_vortex]# pyfr partition 2 euler_vortex_2d.pyfrm .

Traceback (most recent call last):

File "/usr/local/python3/bin/pyfr", line 11, in <module>

load_entry_point('pyfr==1.4.0', 'console_scripts', 'pyfr')()

File "/usr/local/python3/lib/python3.5/site-packages/pyfr-1.4.0-py3.5.egg/pyfr/scripts/", line 109, in main

File "/usr/local/python3/lib/python3.5/site-packages/pyfr-1.4.0-py3.5.egg/pyfr/scripts/", line 156, in process_partition

RuntimeError: No partitioners available

what’s wrong with this case? Please help me.

Thanks in advance.

Best regards,

Do you have scotch or metis installed?

I have the same issue with pyFR.
When I type pyfr partition 2 euler_vortex_2d.pyfrm.

I get :

Traceback (most recent call last):
  File "/home/thomas/miniconda3/bin/pyfr", line 11, in <module>
    load_entry_point('pyfr==1.7.0', 'console_scripts', 'pyfr')()
  File "/home/thomas/miniconda3/lib/python3.6/site-packages/pyfr-1.7.0-py3.6.egg/pyfr/", line 110, in main
  File "/home/thomas/miniconda3/lib/python3.6/site-packages/pyfr-1.7.0-py3.6.egg/pyfr/", line 158, in process_partition
RuntimeError: No partitioners available

is there a solution to this?
I think I have installed scotch and metis correctly.

Kind Regards,

Hi Tom,

If you have built them as shared libraries, did you remember to add

export LD_LIBRARY_PATH=/path/to/your/metis/lib:$LD_LIBRARY_PATH ?


Thanks Niki,

the export didn’t work but i found an easier way to install metis by typing in terminal:
conda install -c menpo metis

Have a good day,


Hello Tom,

I installed the metis in Win10 with the script “conda install -c menpo metis” and typed “pyfr partition 2 euler_vortex_2d.pyfrm .” in the Anaconda prompt. A error occurs with

"AttibuteError : function ‘METIS_SetDefaultOptions’ not found". The path of metis.lib has been added into the system variable. Any suggestions to this error?

You will want to check what version of METIS has been installed by
conda. PyFR requires the newer version 5 however many package managers
ship 4 by default.

Regards, Freddie.

Thank you Freddie.

Also see Error : No partitioners available

I have closed this topic due to age.