Encountering error 'minimum sized time step rejected' while increasing the resolution of grid

Hi all,

I am facing a very weird problem in PyFR. I am trying to run a simple cylinder case similar to that of PyFR tutorial, meshing it using the GMsh. When I am running the case with nodes 8726 the simulations run perfectly and I am able to get the results (not sure if accurate or not). But if I refine the mesh say about 21610 nodes, the simulations are not running at all and giving an error which says “minimum sized time step rejected”. From the previous posts in this group I even tried with the option of – anti-alias = flux, surf-flux ; but this too haven’t helped. I even tried to decrease the order from 3 to 1 but again haven’t worked for me. I have attached my ini file herewith. Any suggestion/comment will be a great help. Thanks in advance!

2dcylinder_forum.ini (1.63 KB)


it’s a bit hard to guess what’s going wrong, however, have you tried reducing the dt?
Another thing, if the diameter of your cylinder is 1, then your Reynolds number is 67665, which is not small, and you should expect a turbulent wake at least. Is this the intended case?


Hello Giogio,
Many thanks for your reply. Yes I tried to reduce the time stepping also. Although not sure, if that is being already taken care by itself in the PyFR code by changing the dt according to the stability etc., please correct if my assumption is wrong. No infact the velocity is pretty low ~0.9 and the flow is in laminar regime, may be strictly transition. If suppose that it is turbulent, what extra input I have to consider? Any suggestions ? My simulations are not been able to start with the increase in the nodes, just at the very starting I am getting the error.