PyFR 1.15.0 Run Issue: libxsmm

Hi All,

I’m trying run Pyfr on Rhel8.5.
The other packages versions:

  • Python 3.9.16
  • libxsmm-1.17
  • gcc-8.5.0 (RHEL8.5 Default)
  • OpenMPI-4.1.2
  • PyFR 1.15.0 (install ed with Pip)
    I built the libxsmm from source with documentation and when ı run
    “mpiexec -n 8 pyfr -b openmp -p euler-vortex.pyfrm euler-vortex.ini”

I’m getting the error.
“AttributeError: /home/libxsmm/libxsmm-1.17/lib/ undefined symbol: libxsmm_fsspmdm_create”

With PyFR-1.12.0 ı don’t get any error with same configuration.
Is there something i’m missing?
I tried build the libxsmm on the local disk and share storage. The result is same.

Any suggestions?
Thank all.

Your version of libxsmm is too old. From the installation guide:

libxsmm >= commit 0db15a0da13e3d9b9e3d57b992ecb3384d2e15ea compiled as a shared library (STATIC=0) with BLAS=0.

The absolute latest git revision of libxsmm contains some breaking changes, so I would go for that exact revision.

Regards, Freddie.

Hi Freddie,

I’m not sure why first time ı get error with this commit but ı decide use the stable release. But this time it works.
Thanks a alot.